Установка WordPress на Ubuntu 15.04

Дата публикации:Август 29, 2015

ubuntuwp

В данном руководстве мы рассмотрим, как установить WordPress на сервер с Ubuntu 15.04. Мы будем исходить из предположения, что у вас уже установлена система Ubuntu и имеется root- или административный доступ к серверу. В противном случае вы не сможете воспользоваться инструкциями, представленными ниже. Поэтому сначала установите Ubuntu и войдите под root-пользователем.

Стоит помнить, что для функционирования WordPress требуется стек LAMP/LEMP. Стек LAMP/LEMP – это самый популярный open source стек, существующий сегодня и используемый большинством веб-сайтов. Он представляет собой набор open source программ и серверов.

Стек LAMP состоит из Linux OS, Apache2 (Nginx или любой другой open source сервер), MySQL (или MariaDB), а также PHP. Собственно, это фундамент для большинства работающих сегодня сайтов. Поэтому для начала нам понадобится включить стек LAMP.

Теперь, когда мы установили Ubuntu 15.04, мы можем переходить к установке Apache2, MySQL и PHP.

Для начала давайте обновим свой Ubuntu сервер. Сделать это можно при помощи следующей команды:

sudo apt-get update && sudo apt-get dist-upgrade && sudo apt-get autoremove

Вам, возможно, понадобится перезапустить сервер Ubuntu после выполнения данных команд. После перезапуска можно продолжить установку стека LAMP.

Установка Apache2

Чтобы установить Apache2, достаточно выполнить команду:

sudo apt-get install apache2

Установка MySQL

После установки Apache2 выполним следующую команду для установки MySQL:

sudo apt-get install mysql-server mysql-client

После установки MySQL выполним команду ниже для защиты MySQL сервера:

sudo mysql_secure_installation

Далее отвечаем на вопросы:

  • Enter current password for root (enter for none): вводим root-пароль
  • Change the root password? Вводим Y
  • Remove anonymous users? Вводим Y
  • Disallow root login remotely? Вводим Y
  • Remove test database and access to it? Вводим Y
  • Reload privilege tables now? Вводим Y

Устанавливаем PHP5 и другие модули

После установки сервера базы данных выполняем команды ниже для установки PHP5 и других PHP-модулей:

sudo apt-get install php5 libapache2-mod-php5

Можно установить и другие PHP-модули с помощью команд ниже. Чтобы WordPress функционировал корректно, вам нужно будет установить следующие модули:

sudo apt-get install php5-mysql php5-curl php5-gd php5-intl php-pear php5-imagick php5-imap php5-mcrypt php5-memcache php5-ming php5-ps php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl

На данный момент мы имеем установленные Apache2, MySQL и PHP.

Чтобы установить WordPress, давайте воспользуемся следующими командами для загрузки последней версии:

cd /tmp/ && wget http://wordpress.org/latest.tar.gz

Затем выполняем команды ниже для извлечения загруженного файла:

tar -xvzf latest.tar.gz

Поскольку дефолтный root-каталог Apache2 на сервере Ubuntu – это /var/www/html, нам нужно будет скопировать контент WordPress в данную root-директорию. Все, что находится в данном каталоге, будет использовано веб-сервером.

Чтобы скопировать контент WordPress в корневую директорию Apache2, воспользуйтесь командой ниже:

sudo mv wordpress/* /var/www/html/

Единственное, в чем вам нужно убедиться – то, что тестовая страница index.html не присутствует в root-каталоге. Если она находится там, удалите ее.

После копирования всех файлов WordPress в root-каталог, вам нужно будет создать базу данных WordPress. База данных требуется WordPress для сохранения контента. Давайте создадим ее. Сделать это можно с помощью следующих шагов.

Выполните команду ниже для входа в базу данных:

mysql -u root -p

Вас попросят ввести root-пароль, который вы создали в начале руководства. Введите его.

Выполните команду ниже для создания новой базы данных под названием wpdb:

CREATE DATABASE wpdb;

Далее выполните команду для создания нового пользователя базы данных wpuser с новым паролем:

CREATE USER wpuser@localhost IDENTIFIED BY 'new_password_here';

Выполните команду ниже, чтобы предоставить пользователю полный доступ к новой базе данных:

GRANT ALL ON wpdb.* to wpuser@localhost;

Наконец, выполните команду ниже для обновления таблицы БД с правами доступа:

FLUSH PRIVILEGES;

Далее выходим при помощи exit.

После создания базы данных скопируйте wp-config-sample.php и создайте новый файл wp-config.php. Новый файл будет содержать в себе параметры соединения с базой данных WordPress.

sudo cp /var/www/html/wp-config-sample.php /var/www/html/wp-config.php

После этого откройте и отредактируйте новый файл с помощью следующей команды:

sudo vi /var/www/html/wp-config.php

Внесите изменения в файл, указав базу данных, имя пользователя и пароль. Сохраните файл и выйдите из него.

// ** MySQL settings – You can get this info from your web host ** //
/** The name of the database for WordPress */
define(‘DB_NAME’, ‘wpdb‘);

/** MySQL database username */
define(‘DB_USER’, ‘wpuser‘);

/** MySQL database password */
define(‘DB_PASSWORD’, ‘password‘);

Наконец, смените права доступа к папке WordPress. Сделать это можно при помощи следующей команды:

sudo chown -R www-data:www-data /var/www/html/
 sudo chmod -R 755 /var/www/html/

Перезапустите веб-сервер Apache2, выполнив команду:

sudo service apache2 restart

Теперь вы сможете получить доступ к странице WordPress. Откройте ваш браузер и введите имя сервера или IP-адрес. Вы должны увидеть стандартную страницу установки WordPress.

wordpress_ubuntu_1410

Источник: liberiangeek.net

Поделиться

17 комментариев

  1. Мне вот не удалось настроить поддержку препроцессора less. Правда на CentOS 6.5…

  2. Я один заметил что на скрине сайт открыт в ie ?

  3. lilia says:

    Несомненно Ubuntu надежней Windows но какие кроме этого плюсы можно получить от установки WP на другую платформу, уязвимости движка как такового не куда не денутся, по крайней мере это мое мнение

    • Вы сейчас про Windows Server говорите и про ISS?

      • Дмитрий says:

        Lilia, какие еще «уязвимости движка»?

        • Самая распространенная уязвимость — пароль вида любимый ник + телефон или день рождения или просто свой телефон, день рождения

          • Дмитрий says:

            Анатолий, это не «уязвимость движка», это проблема самих пользователей, что они ставят такие пароли.

            • Но пользователи считают что это его уязвимость!

              • Дмитрий says:

                Это уже вопрос технической грамотности пользователей.

                Аналогичная ситуация: если сайт пользователя взломали из-за того, что один из плагинов был уязвимым, человек считает, что виновата именно система WordPress. Это, опять же, вопрос слабой технической грамотности. Нужно старательно обучать пользователей.

                • Дмитрий says:

                  Взломать именно саму систему WordPress очень и очень сложно, особенно учитывая ее постоянные обновления и усовершенствования.

              • Нужно прямо на этапе установки делать минитест пользователя: 4 варианта с вопросом какой из этих паролей можно взломать методом социальной инженерии, 5 вариант — А что такое взлом методом социальной инженерии?
                Не прошел — двухфакторная авторизация прибивается к блогу гвоздями из коробки.

                • Дмитрий says:

                  Ну сейчас уже ввели индикатор сложности пароля, который показывает, насколько пароль удачно подобран. Хоть какая-то подсказка для пользователя, что не нужно ставить пароли вида «123123»

  4. Для WordPress я бы предпочел полностью отказаться от apache и заменить его на nginx в связке с PHP 7.

Оставить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Получать новые комментарии по электронной почте. Вы можете подписаться без комментирования.