В каталоге плагинов WordPress.org появилась возможность вывода минимальной версии PHP

Дата публикации:Сентябрь 5, 2017

Хотя в настоящее время ядро WordPress поддерживает обратную совместимость с PHP 5.2.4+, разработчикам тем и плагинов не обязательно придерживаться того же самого. Подключение возможностей, требующих более поздних версий PHP, может вести к поломке сайтов. В рамках своей стратегии по обновлению пользовательских PHP версий каталог WordPress.org теперь позволяет авторам плагинов указывать минимальные требования к PHP в файле readme.txt с помощью нового заголовка Requires PHP. Он выводится сбоку в описании плагина.

Это дополнение к файлу readme.txt было тепло встречено разработчиками, которые уже начали постепенно обновлять свои плагины в каталоге, указывая минимальные требования PHP. Это также позволяет поддержать усилия команды ядра WordPress по обучению пользователей всем преимуществам обновления PHP, поскольку минимально поддерживаемая версия была выпущена еще 10 лет назад и не получала никаких обновлений безопасности примерно 7 лет.

«Как разработчик плагинов (который работает над ними в свободное время), скажу, что становится все труднее создавать новые функции, которые бы работали со старыми версиями PHP», — отметил Paul Gilzow. – «Есть несколько вещей, которые попросту невозможно сделать в более ранних версиях, и в этих случаях мне приходится создавать функционал, чтобы проверять PHP-версии и отключать данные возможности. Это требует времени и энергии, что в итоге тормозит разработку нововведений».

Участник ядра WordPress Сергей Бирюков сказал, что следующим шагом станет изучение возможностей по выводу уведомлений для пользователей, которые не могут установить тему или плагин в результате того, что их базовые установки не соответствуют минимальным требованиям. В идеале эти уведомления будут включать в себя инструкции, зависящие от хостингов, чтобы помочь пользователям обновить сайты до более свежей версии PHP. Этот шаг может существенно повлиять на все сообщество WordPress, если популярные плагины начнут выводить уведомления с требованием современных версий PHP.

Источник: wptavern.com

Поделиться

3 комментария

  1. Спасибо за информацию. Проверим как оно работает.

    Сам всегда проверяю на версии 5.6 7.0 и 7.1 свои творения.
    Но меньшие версии пыха никому не советую использовать — зачем тянуть прошлый век, да и тот который сами разрабы php оставили в покое?

    Если выясняется что проблема у пользователя — потому что у него версия php ниже 5.6 — я его заставляю обновлять его. ниже 5.6 вообще не веду поддержку — т.к. я ценю свое время.

    Ну это как с версткой — используете ie8 и у вас что-то съехало — проблема в вас самих. Не стоит некрофилом быть))

    • Дмитрий says:

      Да, правильно, в принципе. Постепенно и ядро WP подтянется к более свежей версии. Разговоры об этом идут.

  2. Давно пора — легаси код только тормозит развитие. Но у них речь идет о тысячах сайтов используемых старые версии пхп. Им сложно сказать всем — «Это ваши проблемы»…

Оставить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Получать новые комментарии по электронной почте. Вы можете подписаться без комментирования.

Предыдущая запись:

Следующая запись: