Найдена серьезная уязвимость в плагине WP Database Reset

Эксперты установили, что плагин WP Database Reset содержит открытые проблемы безопасности, которые можно использовать для полного захвата уязвимых веб-сайтов.

WP Database Reset используется для сброса баз данных – либо полностью, либо для некоторых таблиц – игнорируя стандартный процесс установки WordPress.

Согласно библиотеке WordPress, плагин активен более чем на 80 тыс. сайтов.

В прошлый четверг команда безопасности Wordfence сообщила о том, что 7 января были найдены 2 серьезных уязвимости. Любая из этих уязвимостей может быть использована для полного сброса или захвата веб-сайта, о чем писала Хлои Чемберленд (Wordfence).

Первая критическая дыра в безопасности (CVE-2020-7048) получила оценку 9.1 по шкале CVSS. Ни одна из функций по сбросу базы данных не была защищена с помощью каких-либо проверок или nonce (одноразовые строки безопасности), а потому любой пользователь мог сбросить любые таблицы базы данных, не проходя аутентификацию.

Все, что надо было сделать – выполнить простой запрос, и в итоге все удалялось за считанные секунды.

Вторая дыра в безопасности (CVE-2020-7047) получила оценку 8.1 по шкале CVSS. Любой аутентифицированный пользователь, вне зависимости от уровня его полномочий, мог назначить себе административные права доступа, а также «убрать всех остальных пользователей из таблицы с помощью простого запроса».

«При сбросе таблицы wp_users все пользователи удалялись из нее, включая любых администраторов, за исключением текущего залогиненного пользователя», – отметила Хлои. – «Пользователь, посылающий такой запрос, автоматически повышался до администратора, даже если он был простым подписчиком».

Соответственно, злоумышленник оставался единственным администратором на сайте. Он мог полностью захватить веб-сайт и получить контроль над CMS.

Разработчик WP Database Reset был проинформирован о проблемах безопасности еще 8 января – сразу после выявления и проверки этой уязвимости. К 14 января был выпущен патч.

Пользователям плагина рекомендуется обновиться до версии WP Database Reset 3.15. На момент написания статьи только 5.2% пользователей выполнили обновление.

Также на прошлой неделе пользователи InfiniteWP Client и WP Time Capsule получили предупреждения о найденных уязвимостях в данных плагинах. Чтобы снизить риски, необходимо обновить плагины до последних версий.

Логические ошибки, обнаруженные в коде, могли использоваться для входа на сайт без пароля. Также вредоносные загрузки, эксплуатирующие эти логические ошибки, позволяли обойти защиту со стороны различных файрволов. По этим причинам важно всегда обновлять используемые плагины.

Источник: https://www.zdnet.com

Понравилась статья? Поделиться с друзьями:
Добавить комментарий

Получать новые комментарии по электронной почте. Вы можете подписаться без комментирования.