DisplayWP представили графики с минимальными версиями PHP для запуска различных релизов WordPress

На днях на сайте DisplayWP, который содержит информацию о различных версиях WP, представленную в удобном для восприятия виде, появились графики минимальных версий PHP для запуска разных релизов WordPress.

Блог Миши Рудрастых

Официальные требования по запуску релизов WP доступны на странице «Requirements» WordPress.org. Кроме того, требуемая PHP-версия также определена в файле version.php.

С выходом WordPress 2.0 в 2005 году минимальной требуемой версией PHP была 4.2. В 2008 году, когда появился WordPress 2.5, от PHP 4.2 решили отказаться в пользу PHP 4.3. Последнее обновление произошло в 2011 году, когда WordPress 3.2 решили перенести с PHP 4.x на PHP 5.2.

Разработчики WordPress всегда пытались создать гибкое программное обеспечение, которое работает с популярными серверными конфигурациями. Но с годами несколько PHP-версий перешли в разряд устаревших.

Обновление до последних версий PHP позволяет разработчикам использовать новые стандарты, писать более эффективный код, осуществлять более быструю обработку и т.д. С другой стороны, обновление требует, чтобы хостинг-компании вкладывали деньги в модернизацию ПО и новую инфраструктуру. Не все компании делают это.

Как следует из диаграмм, WordPress обновлял минимально необходимую версию PHP три раза – каждые три года (2005, 2008 и 2011). Однако уже прошло шесть лет, и обновления так и не было. Текущая минимальная версия PHP уже официально считается устаревшей и больше не поддерживается. По этой причине я считаю, что в 2018 году WordPress должен перейти к PHP 7 в качестве нового стандарта.

Источник: http://displaywp.com

Понравилась статья? Поделиться с друзьями:
Комментарии: 3
  1. petrozavodsky

    По этой причине я считаю, что в 2018 году WordPress должен перейти к PHP 7 в качестве нового стандарта. – Жаль WordPress так не считает.

    1. Дмитрий (автор)

      Да перейдут, вопрос времени.

  2. Yui

    Пока жестко переходить не планируется,
    есть плагины и темы требующие жестко или в виде назойливых всплывающих сообщений в админке более высокой версии.
    Обсуждается инициатива по стимуляции обновления PHP в виде уведомления в админке – https://meta.trac.wordpress.org/ticket/2996

    Пользователей ВП со старыми версиями PHP к сожалению достаточно много,
    лишать их возможности обновлений полностью пока никто не собирается

Добавить комментарий

Получать новые комментарии по электронной почте. Вы можете подписаться без комментирования.