В WordPress 4.8 будет прекращена поддержка Internet Explorer 8,9 и 10

В конце недели Мэтт Мулленвег объявил, что в релизе WordPress 4.8 будет прекращена поддержка IE 8, 9 и 10. Участники ядра обсуждали поддержку браузеров последние два месяца в связи с заданием технических требований для нового редактора.

Microsoft прекратила поддержку IE 8, 9 и 10 в январе 2016 года, т.е. эти версии больше не будут получать обновления безопасности. Мэтт отметил, что попытка поддержки этих браузеров мешает развитию WordPress.

«Я понимаю, что люди, все еще работающие с этими браузерами, вряд ли используют их по своему желанию – возможно, они работают из библиотек или чего-то подобного», – говорит Мэтт. – «Эти браузеры охватывают максимум 3% пользователей, но в любом случае это значение находится ниже порогового, для которого WordPress может продолжать тестирование и разработку».

Чтобы определить, сколько пользователей все еще применяют в работе эти устаревшие и небезопасные браузеры,  Jonathan Desrosiers собрал данные из трех источников. Ниже приведены показатели глобального использования IE, опубликованные GlobalStats, которые, по словам Джонатана, практически идентичны показателям WordPress.com:

  • IE8: 0.41%
  • IE9: 0.26%
  • IE10: 0.26%
  • IE11: 3.79%

WordPress не перестанет полностью работать в этих браузерах, однако все новые функции в релизе 4.8 и выше уже не будут тестироваться в старых версиях IE. Некоторые возможности панели администратора также могут быть ограниченными. Мулленвег подтвердил, что следующие версии TinyMCE уже не будут поддерживать старые версии IE.

Глобальное использование IE упало с 7.44% в марте 2016 до 4.18% в марте 2017. Рыночная доля IE сокращается с ростом использования мобильных устройств. Октябрь 2016 стал первым месяцем в истории, когда трафик мобильных устройств и планшетов превысил трафик настольных компьютеров по всему миру. Учитывая, что использование настольных ПК снижается, IE, скорее всего, будет полностью похоронен в течение нескольких лет.

«Мне было сложно найти правительственное агентство США, которое работало бы с версией IE менее 11», – отметил ведущий разработчик WordPress Эндрю Нейсин. – «Аналогично, правительственные сайты показывают очень малый трафик с версий IE менее 11».

Решение отказаться от поддержки IE 8, 9 и 10 было встречено бурными овациями в стане разработчиков Wordress. Фокус на браузерах, которые все еще получают обновления безопасности – лучший вариант затрат труда и времени для open source разработчиков. Девелоперы, работающие с клиентами, могут ссылаться на политику поддержки IE в WordPress, если клиент будет просить поддержку небезопасных версий браузеров.

Естественно, тема повышения минимальных требований к браузерам привела к тому, что разработчики решили отказаться от поддержки версии PHP 5.2, которая устарела более чем шесть лет назад. В марте 2015 года статистика WordPress показывала, что использование PHP 5.2 находится на уровне 16.6%, однако эти цифры снизились сегодня до 5.1%. Обновление браузера до последней версии – простая задача для пользователей, чего нельзя сказать про обновление версий PHP, поскольку это во многом зависит от хостингов. 5.1% – это миллионы пользователей, которым нужно будет преодолеть значительные препятствия, чтобы воспользоваться актуальной версией WordPress.

Источник: wptavern.com

Понравилась статья? Поделиться с друзьями:
Комментарии: 8
  1. Антон

    За новыми технологиями не поспеваешь, а еще поддерживать древние? Как бы не так! WordPress Молодцы!

  2. Otshelnik-Fm

    Проблема версий php – это проблема хостеров. И когда у хостера php ниже 5.6 (переключиться на эту версию и выше нельзя) – я своим клиентам даю совет бежать от таких ленивых-жадных-глупых хостеров. Во первых это проблемы безопасности, во вторых – правильность работы плагинов. Уже мало плагинов поддерживают 5.4 версию. А сподвигать хостеров, к актуальным версиям, надо рублем. Но нормальные хостеры и так свои виртуальные хостинги предлагают с наборами пыха 5.6, 7.0, 7.1.

    А религия ie 10 и ниже – это вообще отдельная тема. Я никогда не соглашался на подобный мазохизм в поддержке, хотя многие просто увеличивают тариф. Ведь на XP, если она еще жива, можно поставить хром (ну да он будет показывать сообщение что все – финал), или фаерфокс – тот работает без проблем. Ну а библиотеки… Пусть книжки тогда читают со своих полок, а не серфят по интернету.

    1. Антон

      А я однажды согласился несколько страниц верстки сделать с поддержкой от IE6. Это была большая глупость. Лучше уж убедить заказчика, что ни ему, ни его посетителям это не нужно, не согласится – до свидания.

  3. Андрей

    Утверждать что IE вымрет через несколько лет… хм) Только не в России. У нас половина финансового сектора использует IE – 7-9 потому что использует. По разным причинам. И перетащить банковские махины на новые технологии и хромы всяческие забугорные вопрос еще тот.

    1. Дмитрий (автор)

      В банковских политиках безопасности обычно прописывается версия IE, которой можно пользоваться. Сейчас прописывают от 11 и выше. Смотря, какие банки вы имеете в виду. Возможно, что в каких-то и используют, но вообще это создает угрозы безопасности. А уж в контексте с WP для банков это совсем неактуально, поскольку обычно они используют самописные CMS.

  4. Руслан

    Как по мне internet explorer нужен только для скачивания других браузеров не более

    1. Дмитрий (автор)

      Обычным юзерам – да :)

  5. Лев Циммерман

    С учётом того выбора браузеров, который на данный момент есть, IE стоит по популярности на последнем месте. Поэтому и статистика захода через IE совсем невелика. Впрочем, отказ WordPress от него очевидна: безопасность важнее всего, а когда мало пользуются таким браузером, то не стоит под него оптимизироваться. Скоро о нём, возможно, забудут как о Windows 98

Добавить комментарий

Получать новые комментарии по электронной почте. Вы можете подписаться без комментирования.