Выбор необходимых компонентов для плагина jQuery UI

Дата публикации:Апрель 18, 2011

Преимущество загрузки плагина jQuery UI с официального сайта заключается в том, что вы всегда можете выбрать те компоненты, в которых действительно нуждаетесь при работе с проектом. Если вы посетите страницу загрузки http://www.jqueryui.com/download, то сможете увидеть, что вам доступны для выбора несколько версий плагина: 1.7.3 и 1.8.4. Щелчок по кнопке Download позволяет загрузить нужную версию jQuery UI.

Вы всегда можете скачать полную версию плагина, которая упакована в ZIP архив и занимает примерно 4 Мбайта. Преимуществом данной версии является наличие различных примеров использования плагина и полноценной документации по каждой его возможности.

Вместе со всеми отмеченными настройками .js файл плагина будет занимать приблизительно 200 Кбайт. Если вы точно знаете, какие настройки вам необходимы, вы можете выполнить избирательную установку, которая позволит вам сократить размер плагина.

Страница загрузки плагина выполнена великолепно. Вы не сможете загрузить компонент, который построен на базе других необходимых функций. Вместо этого вам будет выдано соответствующее сообщение:

Теперь несколько слов о том, как выбрать подходящую версию плагина. Если вы используете в вашем проекте WordPress 2.9.2, который поставляется с jQuery 1.3.2, то вам понадобится загрузить плагин jQuery UI версии 1.7.3. Если вы используете Google CDN или самостоятельно подключили к теме JQuery 1.4+, то в таком случае вам понадобится jQuery UI 1.8+.

Поделиться

Оставить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Получать новые комментарии по электронной почте. Вы можете подписаться без комментирования.