Вышел WordPress 5.1.1: исправлена критическая уязвимость

Дата публикации:Март 14, 2019

На днях вышел релиз WordPress 5.1.1, в котором было представлено важное обновление безопасности, связанное с XSS-уязвимостью. Уязвимость найдена в 5.1 и более ранних версиях. В посте с релизом благодарность выражается Саймону Сканнеллу из RIPS Technologies за раскрытие и описание уязвимости. Саймон опубликовал пост, в котором разъяснил, как неавторизованный злоумышленник может получить контроль над любым WordPress-сайтом с открытыми комментариями:

«Злоумышленник может получить контроль над любым сайтом WordPress с открытыми комментариями, заставив (разными способами) администратора целевого блога посетить сайт, созданный злоумышленником. Как только администратор посетит такой вредоносный сайт, будет выполнен CSRF эксплойт в фоновом режиме. Этот эксплойт использует различные недостатки логики и ошибки санитизации, что приводит к удаленному выполнению кода и получению контроля над сайтом»

Поскольку WordPress поставляется с включенными по умолчанию комментариями, злоумышленники могут использовать уязвимость на любом сайте с базовыми настройками. Вчера вышли автообновления, но администраторам с выключенными фоновыми обновлениями стоит установить апдейт немедленно.

Технический релиз также включил в себя возможность введения отдельной кнопки (для хостингов) с предложением обновить PHP до новой минимальной версии. Уведомление «Update PHP» может быть отфильтровано для изменения рекомендуемой версии в каждом конкретном случае.

Версия 5.1.2 должна выйти через пару недель.

Источник: wptavern.com

Оставить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Получать новые комментарии по электронной почте. Вы можете подписаться без комментирования.