Версия WordPress 4.5.1: исправлено 12 багов

Дата публикации:Апрель 27, 2016

WordPress 4.5.1 стал доступен для установки. Новая версия исправляет найденные ошибки и проблемы, отмеченные в WordPress 4.5. Согласно Адаму Сильверстейну, «исправлена проблема с классом singular, который затрагивал сайты, основанные на теме Twenty Eleven, исправлена несовместимость между отдельными версиями Chrome и визуальным редактором, а также исправлен баг в Imagick, который мог приводить к проблемам с загрузкой медиафайлов». Полный список изменений можно посмотреть здесь.

updatewp

WordPress 4.5.1 был уже установлен на сайты с настроенным автоматическим обновлением. Если вы не хотите ждать установки или у вас отключена эта опция, вы можете перейти в раздел «Консоль» – «Обновления» и щелкнуть по кнопке «Установить». Если вы столкнулись с какими-либо проблемами или считаете, что обнаружили ошибку, вы всегда можете отписаться в соответствующем разделе на форумах поддержки.

Поделиться

13 комментариев

  1. Как раз сегодня получил на почту сообщение, что мой WordPress обновлен автоматически до версии 4.5.1)) Хотя конкретно я не замечал проблем с версией 4.5, но все равно здорово, что CMS постоянно обновляется.

  2. Евгений says:

    У меня в 4.5 проблема со слайдером на сайте(не отображает), еще не обновлялся, нужно попробывать

    • Евгений says:

      … обновил, ничего не поменялось)

      • Looler says:

        Значит проблема в шаблоне или в плагине самого слайдера. Попробуйте тот же слайдер встроить в другой шаблон или просто на тестовом сайте, например на локалке. Можете еще включить режим «дебага» и отследить проблему.

        • Евгений says:

          Слайдер на wp 4.3 и 4.4 работает отлично, проблема не в нем.

          • Дмитрий says:

            Тогда ждать, пока доработают слайдер его разработчики. Обычно, если плагин раньше обновлялся оперативно, то и в новой версии он должен быть доработан. Посмотрите форумы поддержки, может там тоже есть подобные ответы от пользователей. Или опубликуйте свой ответ, чтобы разработчик быстрее среагировал.

            • Looler says:

              Скорее всего в новой версии WP была окончательно убрана поддержка какой то функции, которая используется в плагине. Если плагин с живым сообществом и поддержкой автора, то думаю проблему решат скоро. А лучше напишите сами им.

              • Скорее всего несовместимая версия JS (в новых WP ее увеличили). Попробуйте переподключить старую) в functions.php добавьте для теста:

                if( !is_admin()){
                wp_deregister_script(‘jquery’);
                wp_register_script(‘jquery’, («http://ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js»), false, ‘1.11.3’);
                wp_enqueue_script(‘jquery’);
                }

  3. aliprofi says:

    А я вот с ветки 4.3 перестал обновляться, что-то мне эти нововведения вообще не понравились!

    • Looler says:

      Дело Ваше конечно, но советую тщательно и внимательно отслеживать испрвления всех обновлении, так как у Вашей версии могут быть серьезные уязвимости.
      Удачи!

  4. Столкнулся с такой же проблемой — не стали работать скрипты после обновления до 4.5.

    Вячеслав, этот код лучще чуть изменить:
    Если писать в названии скрипта ‘jquery-core’, а не ‘jquery’ то WordPress подключит плагин migrate для поддержки скриптов написанных под старую версию библиотеки.

    wp_deregister_script( ‘jquery-core’ );
    wp_register_script( ‘jquery-core’, ‘https://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js’);
    wp_enqueue_script( ‘jquery’ );

  5. Art says:

    на 4.3 — полет без проблем
    каджое обновление — очкую =)

  6. Спасибо за статью! Очень много полезной инфы!

Оставить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Получать новые комментарии по электронной почте. Вы можете подписаться без комментирования.