TinyMCE 4.0 добавлен в ядро WordPress

Дата публикации:Январь 21, 2014

Эндрю Озз, ответственный за поддержание TinyMCE в WordPress, объявил на днях, что TinyMCE 4.0 был включен в ядро. Обновление содержит в себе массу изменений, среди которых:

  • Новый интерфейс и API для него
  • Новая тема
  • Обновленная система событий и API событий.
  • Улучшенное качество кода, читабельность и процесс создания
  • Множество встроенной документации
  • Общие улучшения

TinyMCE40Interface

Все TinyMCE плагины, а также произвольные плагины, используемые в WordPress, обновились для совместимости с 4.0. Поскольку появилось множество изменений в API, разработчики плагинов должны модернизировать свои решения, чтобы реализовать совместимость с 4.0, после чего протестировать их в транке WordPress.

Эндрю Озз назвал три группы общих TinyMCE плагинов, которые реализованы в виде WordPress-плагинов:

  • Произвольный плагин, созданный специально под определенный WordPress-плагин. Если вы разрабатывали такой тип плагинов, то в таком случае вам нужно будет посмотреть руководство миграции с 3.x к 4.0, а также API-документацию по версии 4.0.
  • WordPress-плагины, добавляющие сторонние или стандартные TinyMCE-редакторы, должны обновиться, чтобы включить в себя версию 4.0. Глобальная переменная $tinymce_version может использоваться для определения того, какой плагин загружать.
  • Мини-плагины, которые просто добавляют свою кнопку в панель инструментов. Работают они аналогично. Их желательно тоже обновить, чтобы они использовали текстовые иконки «dashicons» вместо изображений.

TinyMCE40Icons
После обновления до новейшей версии WordPress 3.9 при сравнении текущего визуального редактора с редактором в WordPress 3.8 я заметил, что изображение плагина Pull Quotes куда-то исчезло. Заполнитель по-прежнему остался, и кнопка функционирует как обычно, но изображение иконки пропало. Здесь же представлены два других плагина, которые добавляют произвольные изображения к визуальному редактору, но с ними ничего не произошло. Однако поскольку они не используют изображения SVG или Dashicons, опыт взаимодействия противоречит остальному интерфейсу.

Если вы являетесь автором плагина, который изменяет поведение TinyMCE, то теперь самое время протестировать его в транке WordPress, чтобы пользователи не столкнулись с неожиданными изменениями при обновлении до WordPress 3.9.

Источник: wptavern.com

Поделиться

Оставить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Получать новые комментарии по электронной почте. Вы можете подписаться без комментирования.