Минимальная версия PHP для работы с WordPress поднята до 5.6

Дата публикации:Март 21, 2019

Разработчики WordPress официально прекращают поддержку PHP 5.2 – 5.5 и повышают минимально рекомендуемую версию PHP до 5.6. План, анонсированный в декабре прошлого года, состоял в том, чтобы в начале 2019 года повысить минимальную версию PHP, и, основываясь на полученных результатах, вновь повысить ее до PHP 7 в декабре 2019. Сайты на PHP 5.5 и ранее будут по-прежнему получать обновления безопасности, однако обновить их до последней версии WordPress не удастся.

Сегодня только 2% сайтов WordPress используют версию PHP 5.2. Примерно 20% сайтов используют версию 5.5 и более ранние версии. Почти половина всех установок WordPress работает на PHP 7+.

Кто-то может задаться вопросом: почему WordPress просто не может сразу повысить минимальное требование до PHP 7. Учитывая доминирующее положение системы на рынке, это требование заставило бы пользователей обновиться до необходимой версии. Однако разработчики WordPress считают, что некоторым пользователям может потребоваться помощь в обновлении PHP. Продавливание этого требования – это не путь WordPress, невзирая на годы отчаянных просьб со стороны разработчиков.

«Если мы отбросим часть пользователей по техническим причинам, то мы придем лишь к раздробленной сети», — отметил Феликс Арнтц, разработчик WordPress. – «Взаимодействие с этими пользователями, их всесторонняя поддержка помогут нам перейти к новым требованиям в долгосрочной перспективе».

Гэри Пендергаст поделился статистикой о том, насколько эффективным оказалось уведомление об обновлении PHP до 5.1 в WordPress:

«В случае с WordPress 5.0 владельцы сайтов обновляли версию PHP <= 5.6 до PHP 7+ со скоростью примерно в 1 базисный пункт в день. То есть, говоря простым языком, до выхода WordPress 5.1 процент сайтов с WordPress 5.0, использующих PHP <= 5.6, снижался на 0.01 каждый день.

В случае с WordPress 5.1 (после добавления уведомления об обновлении) этот показатель увеличился до 5 базовых пунктов в день. Каждый день сотни владельцев сайтов решают обновить свою версию PHP. Все, что им требовалось – немного информации и небольшой толчок к этому.

Устрашающие уведомления об окончании срока действия PHP и отношение по типу «сорри, мы решили поднять минимальную версию PHP; если вы не в курсе, что делать – проблемы ваши» — все это никак не поможет. Пользователям нужна информация о том, что и как делать.

Мы делаем все возможное, чтобы избавиться от устаревших PHP установок, которые используются в сети. И это далеко не непреодолимая проблема. Просто нужно чуть больше терпения и внимания к пользователям»

Разработчики WordPress по всему миру стали активно публиковать радостные твиты, связанные с повышением минимальной версии PHP. И хотя PHP 5.6 является новой минимальной версией для запуска WordPress, страница технических требований проекта рекомендует пользователям запрашивать у своих хостингов PHP 7.3 и выше. PHP 7+ дает огромный прирост производительности для пользователей. Разработчики смогут обновить свои плагины для использования более современного синтаксиса.

Источник: wptavern.com

2 комментария

  1. Eldar says:

    Давно пора было это сделать. Может наконец-то в код WordPress добавят пространства имен, которые появились в PHP 5.3. И вообще было бы неплохо в будущем переписать код WP с учетом новшеств PHP 7+

    • Дмитрий says:

      Многие разработчики плагинов уже обновили свой код и ввели пространства имен. В скором времени и WP это сделает.

Оставить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Получать новые комментарии по электронной почте. Вы можете подписаться без комментирования.